Project

General

Profile

Bug #117

Failure to function when compiled with GCC 5

Added by Kyle Marek almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Target version:
-
Start date:
01/03/2016
Due date:
% Done:

0%


Description

"Invalid characters encountered" error occurs followed by crash when creating volumes.

History

#1 Updated by Kyle Marek over 2 years ago

  • Status changed from New to Resolved

Addressed in b4de5062848848b21be24a35c3c8dbe8bca3a401.

GCC5 broke backwards compatibility (by default) with libraries compiled with older GCC. This error was caused by an ABI incompatibility. A flag was added to the Makefile to use the old ABI until our dependencies are using the new ABI.

#2 Updated by Kyle Marek over 2 years ago

Corrected resolution in commit 71ca808157731eb329496ef15e2282efa4aed9f8. Released with v0.7.4.1.

Also available in: Atom PDF